{"action":"Upgrade org.jenkins-ci.plugins:ci-with-toad-edge to 2.4 or later.","affected":[{"fixed":"2.4","introduced":"0"}],"component":"org.jenkins-ci.plugins:ci-with-toad-edge","cve_ids":["CVE-2022-28146"],"ecosystem":"Maven","epss":0.01835,"exploited":false,"fixed_versions":["2.4"],"ghsa_id":"GHSA-8p4x-fq8v-xhv4","id":"tcs_01M5N8N4HKEMAZFPH90BB3MBAP","modified_at":"2024-02-16T08:13:45.832656Z","published_at":"2022-03-30T00:00:26Z","references":["https://osv.dev/vulnerability/GHSA-8p4x-fq8v-xhv4","https://nvd.nist.gov/vuln/detail/CVE-2022-28146","https://github.com/jenkinsci/ci-with-toad-edge-plugin/commit/49d4b855773ed4bbc58fc510149ec24d504f80d4","https://github.com/jenkinsci/ci-with-toad-edge-plugin","https://www.jenkins.io/security/advisory/2022-03-29/#SECURITY-2633","http://www.openwall.com/lists/oss-security/2022/03/29/1"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"GHSA-8p4x-fq8v-xhv4","url":"https://osv.dev/vulnerability/GHSA-8p4x-fq8v-xhv4"}],"summary":"Arbitrary file read vulnerability in Jenkins Continuous Integration with Toad Edge Plugin"}