{"action":"Upgrade org.jruby:jruby-stdlib to 9.1.16.0 or later.","affected":[{"fixed":"9.1.16.0","introduced":"0"}],"component":"org.jruby:jruby-stdlib","cve_ids":["CVE-2018-1000079"],"ecosystem":"Maven","epss":0.02779,"exploited":false,"fixed_versions":["9.1.16.0"],"ghsa_id":"GHSA-8qxg-mff5-j3wc","id":"tcs_01M5N8N9VT5R944KGSSMS9JNY7","modified_at":"2024-03-12T05:17:45.020266Z","published_at":"2022-05-14T01:54:40Z","references":["https://osv.dev/vulnerability/GHSA-8qxg-mff5-j3wc","https://nvd.nist.gov/vuln/detail/CVE-2018-1000079","https://github.com/rubygems/rubygems/commit/f83f911e19e27cbac1ccce7471d96642241dd759","https://github.com/rubygems/rubygems/commit/666ef793cad42eed96f7aee1cdf77865db921099","https://github.com/jruby/jruby/commit/0b06b48ab4432237ce5fc1bef47f2c6bcf7843f7","https://github.com/rubygems/rubygems/commit/5971b486d4dbb2bad5d3445b3801c456eb0ce183","https://www.debian.org/security/2018/dsa-4259","https://www.debian.org/security/2018/dsa-4219","https://usn.ubuntu.com/3621-1","https://security-tracker.debian.org/tracker/CVE-2018-1000079","https://lists.debian.org/debian-lts-announce/2018/07/msg00012.html","https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=895778","https://access.redhat.com/errata/RHSA-2020:0663","https://access.redhat.com/errata/RHSA-2020:0591","https://access.redhat.com/errata/RHSA-2020:0542","https://access.redhat.com/errata/RHSA-2019:2028","https://access.redhat.com/errata/RHSA-2018:3731","https://access.redhat.com/errata/RHSA-2018:3730","https://access.redhat.com/errata/RHSA-2018:3729","http://blog.rubygems.org/2018/02/15/2.7.6-released.html","http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00036.html"],"severity":{"label":"medium","score":5.5},"sources":[{"source":"osv","source_id":"GHSA-8qxg-mff5-j3wc#Maven/org.jruby:jruby-stdlib","url":"https://osv.dev/vulnerability/GHSA-8qxg-mff5-j3wc"}],"summary":"RubyGems Path Traversal vulnerability"}