{"action":"Upgrade org.jenkins-ci.plugins.workflow:workflow-cps to 2.79 or later.","affected":[{"fixed":"2.79","introduced":"0"}],"component":"org.jenkins-ci.plugins.workflow:workflow-cps","cve_ids":["CVE-2020-2109"],"ecosystem":"Maven","epss":0.01257,"exploited":false,"fixed_versions":["2.79"],"ghsa_id":"GHSA-99mf-f3qh-wqrp","id":"tcs_01M5N8PPPFG0HNVZJ0JHR6D4KC","modified_at":"2024-02-16T08:24:15.997671Z","published_at":"2022-05-24T17:08:46Z","references":["https://osv.dev/vulnerability/GHSA-99mf-f3qh-wqrp","https://nvd.nist.gov/vuln/detail/CVE-2020-2109","https://github.com/jenkinsci/workflow-cps-plugin/commit/41cb4e05eed6a901d0c8a8b0a460111a64c5e179","https://github.com/jenkinsci/workflow-cps-plugin/commit/90b7f403882e1cab1dec49a011e377f440f8e003","https://jenkins.io/security/advisory/2020-02-12/#SECURITY-1710","http://www.openwall.com/lists/oss-security/2020/02/12/3"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"GHSA-99mf-f3qh-wqrp","url":"https://osv.dev/vulnerability/GHSA-99mf-f3qh-wqrp"}],"summary":"Improper Input Validation in Jenkins Pipeline: Groovy Plugin"}