{"action":"Upgrade org.springframework:spring-expression to 5.3.39 or later.","affected":[{"fixed":"5.3.39","introduced":"0"}],"component":"org.springframework:spring-expression","cve_ids":["CVE-2024-38808"],"ecosystem":"Maven","epss":0.00568,"exploited":false,"fixed_versions":["5.3.39"],"ghsa_id":"GHSA-9cmq-m9j5-mvww","id":"tcs_01M5N8PT5MR53TTEZ0MNE97AMZ","modified_at":"2026-09-10T03:50:17.479530568Z","published_at":"2024-08-20T09:30:28Z","references":["https://osv.dev/vulnerability/GHSA-9cmq-m9j5-mvww","https://nvd.nist.gov/vuln/detail/CVE-2024-38808","https://github.com/spring-projects/spring-framework/commit/26f2dad388499faecf99e75b8856788e95d8d658","https://github.com/spring-projects/spring-framework/commit/f44d13cb7816e586b86c02421af4f5498391111c","https://github.com/spring-projects/spring-framework","https://security.netapp.com/advisory/ntap-20240920-0002","https://spring.io/security/cve-2024-38808"],"severity":{"label":"medium","score":4.3},"sources":[{"source":"osv","source_id":"GHSA-9cmq-m9j5-mvww","url":"https://osv.dev/vulnerability/GHSA-9cmq-m9j5-mvww"}],"summary":"Spring Framework vulnerable to Denial of Service"}