{"action":"Upgrade com.redgate.plugins.redgatesqlci:redgate-sql-ci to 2.0.4 or later.","affected":[{"fixed":"2.0.4","introduced":"0"}],"component":"com.redgate.plugins.redgatesqlci:redgate-sql-ci","cve_ids":["CVE-2019-16557"],"ecosystem":"Maven","epss":0.00852,"exploited":false,"fixed_versions":["2.0.4"],"ghsa_id":"GHSA-9hpq-528p-48j3","id":"tcs_01M5N8Q4T2F24N9MK2R7FPF2MD","modified_at":"2024-02-16T08:24:58.603545Z","published_at":"2022-05-24T17:03:47Z","references":["https://osv.dev/vulnerability/GHSA-9hpq-528p-48j3","https://nvd.nist.gov/vuln/detail/CVE-2019-16557","https://github.com/jenkinsci/redgate-sql-ci-plugin/commit/18525ee6f01a5bc36040d40f1ff63702ce7280ac","https://jenkins.io/security/advisory/2019-12-17/#SECURITY-1598","http://www.openwall.com/lists/oss-security/2019/12/17/1"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"GHSA-9hpq-528p-48j3","url":"https://osv.dev/vulnerability/GHSA-9hpq-528p-48j3"}],"summary":"Jenkins Redgate SQL Change Automation Plugin has Insufficiently Protected Credentials"}