{"action":"Upgrade org.jenkins-ci.plugins:pipeline-build-step to 2.18.1 or later.","affected":[{"fixed":"2.18.1","introduced":"0"}],"component":"org.jenkins-ci.plugins:pipeline-build-step","cve_ids":["CVE-2023-25762"],"ecosystem":"Maven","epss":0.82131,"exploited":false,"fixed_versions":["2.18.1"],"ghsa_id":"GHSA-9j65-3f2q-8q2r","id":"tcs_01M5N8Q6TK8SKV5WPNXHK9ZMM2","modified_at":"2024-02-16T08:02:23.294692Z","published_at":"2023-02-15T15:30:41Z","references":["https://osv.dev/vulnerability/GHSA-9j65-3f2q-8q2r","https://nvd.nist.gov/vuln/detail/CVE-2023-25762","https://github.com/jenkinsci/pipeline-build-step-plugin/commit/0eaf88a695244ddb69d16c11b96659167dbead92","https://github.com/jenkinsci/pipeline-build-step-plugin","https://www.jenkins.io/security/advisory/2023-02-15/#SECURITY-3019","http://www.openwall.com/lists/oss-security/2023/02/15/4"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"GHSA-9j65-3f2q-8q2r","url":"https://osv.dev/vulnerability/GHSA-9j65-3f2q-8q2r"}],"summary":"Cross-site Scripting in Jenkins Pipeline: Build Step Plugin"}