{"action":"Upgrade com.typesafe.akka:akka-http-core_2.12 to 10.1.4 or later.","affected":[{"fixed":"10.1.4","introduced":"10.1.0"}],"component":"com.typesafe.akka:akka-http-core_2.12","cve_ids":["CVE-2018-16131"],"ecosystem":"Maven","epss":0.03054,"exploited":false,"fixed_versions":["10.1.4"],"ghsa_id":"GHSA-9qgc-p27w-3hjg","id":"tcs_01M5N8QJ0F5XYJVFFRX2MTAYCH","modified_at":"2023-11-08T03:59:58.719943Z","published_at":"2018-10-22T20:37:07Z","references":["https://osv.dev/vulnerability/GHSA-9qgc-p27w-3hjg","https://nvd.nist.gov/vuln/detail/CVE-2018-16131","https://github.com/akka/akka-http/issues/2137","https://akka.io/blog/news/2018/08/30/akka-http-dos-vulnerability-found","https://doc.akka.io/docs/akka-http/current/security/2018-09-05-denial-of-service-via-decodeRequest.html","https://github.com/advisories/GHSA-9qgc-p27w-3hjg","https://groups.google.com/forum/#!topic/akka-security/Dj7INsYWdjg"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-9qgc-p27w-3hjg","url":"https://osv.dev/vulnerability/GHSA-9qgc-p27w-3hjg"}],"summary":"High severity vulnerability that affects com.typesafe.akka:akka-http-core_2.11 and com.typesafe.akka:akka-http-core_2.12"}