{"action":"Upgrade curl to 7.52.1-r0 or later.","affected":[{"fixed":"7.52.1-r0","introduced":"0"}],"component":"curl","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.2","exploited":false,"fixed_versions":["7.52.1-r0"],"id":"tcs_01M5N8QJXJDD83F6EF4CEGQ2F6","modified_at":"2026-09-22T06:30:11.980771731Z","published_at":"2018-04-23T18:29:00.537Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2016-9586","https://security.alpinelinux.org/vuln/CVE-2016-9586"],"severity":{"label":"high","score":8.1},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2016-9586","url":"https://osv.dev/vulnerability/ALPINE-CVE-2016-9586"}],"summary":"curl before version 7.52.0 is vulnerable to a buffer overflow when doing a large floating point output in libcurl's implementation of the printf() functions. If there are any application that accepts"}