{"action":"Upgrade ansible to 2.1.4.0-r0 or later.","affected":[{"fixed":"2.1.4.0-r0","introduced":"0"}],"component":"ansible","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.4","exploited":false,"fixed_versions":["2.1.4.0-r0"],"id":"tcs_01M5N8QK902YAY656RTZS6F4V0","modified_at":"2026-09-22T06:30:32.422379233Z","published_at":"2018-04-24T16:29:00.220Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2016-9587","https://security.alpinelinux.org/vuln/CVE-2016-9587"],"severity":{"label":"high","score":8.1},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2016-9587","url":"https://osv.dev/vulnerability/ALPINE-CVE-2016-9587"}],"summary":"Ansible before versions 2.1.4, 2.2.1 is vulnerable to an improper input validation in Ansible's handling of data sent from client systems. An attacker with control over a client system being managed b"}