{"action":"Upgrade squid to 2.6.5-4 or later.","affected":[{"fixed":"2.6.5-4","introduced":"0"}],"component":"squid","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.6.5-4"],"id":"tcs_01M5N8QT8EEFP8ZJKKB0VFHGFP","modified_at":"2026-10-21T17:47:32.939384907Z","published_at":"2007-01-16T18:28:00Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2007-0248","https://security-tracker.debian.org/tracker/CVE-2007-0248"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2007-0248#Debian:14/squid","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2007-0248"}],"summary":"The aclMatchExternal function in Squid before 2.6.STABLE7 allows remote attackers to cause a denial of service (crash) by causing an external_acl queue overload, which triggers an infinite loop."}