{"action":"Upgrade org.yaml:snakeyaml to 1.32 or later.","affected":[{"fixed":"1.32","introduced":"0"}],"component":"org.yaml:snakeyaml","cve_ids":["CVE-2022-38752"],"ecosystem":"Maven","epss":0.02695,"exploited":false,"fixed_versions":["1.32"],"ghsa_id":"GHSA-9w3m-gqgf-c4p9","id":"tcs_01M5N8QXFXTRF5JDDRWGDJZ6HQ","modified_at":"2026-09-10T03:49:45.319354474Z","published_at":"2022-09-06T00:00:27Z","references":["https://osv.dev/vulnerability/GHSA-9w3m-gqgf-c4p9","https://nvd.nist.gov/vuln/detail/CVE-2022-38752","https://bitbucket.org/snakeyaml/snakeyaml","https://bitbucket.org/snakeyaml/snakeyaml/issues/531/stackoverflow-oss-fuzz-47081","https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=47081","https://security.gentoo.org/glsa/202305-28","https://security.netapp.com/advisory/ntap-20240315-0009"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"GHSA-9w3m-gqgf-c4p9","url":"https://osv.dev/vulnerability/GHSA-9w3m-gqgf-c4p9"}],"summary":"snakeYAML before 1.32 vulnerable to Denial of Service due to Out-of-bounds Write"}