{"action":"Upgrade com.reposilite:reposilite-backend to 3.5.12 or later.","affected":[{"fixed":"3.5.12","introduced":"3.3.0"}],"component":"com.reposilite:reposilite-backend","cve_ids":["CVE-2024-36115"],"ecosystem":"Maven","epss":0.00835,"exploited":false,"fixed_versions":["3.5.12"],"ghsa_id":"GHSA-9w8w-34vr-65j2","id":"tcs_01M5N8QY5X1843YHZWWNACXEXS","modified_at":"2026-09-10T03:50:17.427250914Z","published_at":"2024-08-02T21:12:54Z","references":["https://osv.dev/vulnerability/GHSA-9w8w-34vr-65j2","https://github.com/dzikoysk/reposilite/security/advisories/GHSA-9w8w-34vr-65j2","https://nvd.nist.gov/vuln/detail/CVE-2024-36115","https://github.com/dzikoysk/reposilite/commit/279a472015ec675c1da449d902dc82e4dd578484","https://github.com/dzikoysk/reposilite/commit/d11609f427aba255e0f6f54b1105d5d20ab043cf","https://github.com/dzikoysk/reposilite","https://github.com/dzikoysk/reposilite/releases/tag/3.5.12"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-9w8w-34vr-65j2","url":"https://osv.dev/vulnerability/GHSA-9w8w-34vr-65j2"}],"summary":"Reposilite artifacts vulnerable to Stored Cross-site Scripting"}