{"action":"Upgrade org.apache.geronimo.plugins:console to 2.1.4 or later.","affected":[{"fixed":"2.1.4","introduced":"2.1.0"}],"component":"org.apache.geronimo.plugins:console","cve_ids":["CVE-2009-0038"],"ecosystem":"Maven","epss":0.18003,"exploited":false,"fixed_versions":["2.1.4"],"ghsa_id":"GHSA-c372-x57p-6x7v","id":"tcs_01M5N8R9XSH5EPTEYNT6D1284C","modified_at":"2024-12-03T06:03:41.086365Z","published_at":"2022-05-02T03:12:29Z","references":["https://osv.dev/vulnerability/GHSA-c372-x57p-6x7v","https://nvd.nist.gov/vuln/detail/CVE-2009-0038","https://github.com/apache/geronimo/commit/aa0c2c26dde8930cad924796af7c17a13d236b16","https://github.com/apache/geronimo","https://web.archive.org/web/20090419162753/http://secunia.com/advisories/34715","https://web.archive.org/web/20090422192202/http://dsecrg.com/pages/vul/show.php?id=119","https://web.archive.org/web/20200229223125/http://www.securityfocus.com/bid/34562","http://geronimo.apache.org/21x-security-report.html#2.1.xSecurityReport-214","http://issues.apache.org/jira/browse/GERONIMO-4597"],"severity":{"label":"medium"},"sources":[{"source":"osv","source_id":"GHSA-c372-x57p-6x7v","url":"https://osv.dev/vulnerability/GHSA-c372-x57p-6x7v"}],"summary":"Apache Geronimo Application Server multiple cross-site scripting (XSS) vulnerabilities"}