{"action":"Upgrade glib2.0 to 2.14.3-1 or later.","affected":[{"fixed":"2.14.3-1","introduced":"0"}],"component":"glib2.0","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2.14.3-1"],"id":"tcs_01M5N8S2XGXK9ZYXGASDZFT2S0","modified_at":"2026-10-21T17:47:41.880818390Z","published_at":"2007-11-07T23:46:00Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2007-1660","https://security-tracker.debian.org/tracker/CVE-2007-1660"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2007-1660#Debian:13/glib2.0","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2007-1660"}],"summary":"Perl-Compatible Regular Expression (PCRE) library before 7.0 does not properly calculate sizes for unspecified \"multiple forms of character class\", which triggers a buffer overflow that allows context"}