{"action":"Upgrade ruby to 2.4.2-r0 or later.","affected":[{"fixed":"2.4.2-r0","introduced":"0"}],"component":"ruby","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.13","exploited":false,"fixed_versions":["2.4.2-r0"],"id":"tcs_01M5N8SFWS1Y73RR22WTCFC861","modified_at":"2026-06-15T18:18:06.719239735Z","published_at":"2017-08-31T20:29:00.417Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2017-0899","https://security.alpinelinux.org/vuln/CVE-2017-0899"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2017-0899#Alpine:v3.13/ruby","url":"https://osv.dev/vulnerability/ALPINE-CVE-2017-0899"}],"summary":"RubyGems version 2.6.12 and earlier is vulnerable to maliciously crafted gem specifications that include terminal escape characters. Printing the gem specification would execute terminal escape sequen"}