{"action":"Upgrade ruby to 2.4.2-r0 or later.","affected":[{"fixed":"2.4.2-r0","introduced":"0"}],"component":"ruby","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.23","exploited":false,"fixed_versions":["2.4.2-r0"],"id":"tcs_01M5N8SS4WRW8DJ33DHZ58489N","modified_at":"2026-06-15T18:18:06.719290550Z","published_at":"2017-08-31T20:29:00.557Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2017-0901","https://security.alpinelinux.org/vuln/CVE-2017-0901"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2017-0901#Alpine:v3.23/ruby","url":"https://osv.dev/vulnerability/ALPINE-CVE-2017-0901"}],"summary":"RubyGems version 2.6.12 and earlier fails to validate specification names, allowing a maliciously crafted gem to potentially overwrite any file on the filesystem."}