{"action":"Upgrade python2 to 2.7.14-r0 or later.","affected":[{"fixed":"2.7.14-r0","introduced":"0"}],"component":"python2","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.6","exploited":false,"fixed_versions":["2.7.14-r0"],"id":"tcs_01M5N8THPFRB5RZ2TQ8G8AMKG9","modified_at":"2026-07-08T04:30:08.755807195Z","published_at":"2017-11-17T05:29:00.280Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2017-1000158","https://security.alpinelinux.org/vuln/CVE-2017-1000158"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2017-1000158#Alpine:v3.6/python2","url":"https://osv.dev/vulnerability/ALPINE-CVE-2017-1000158"}],"summary":"CPython (aka Python) up to 2.7.13 is vulnerable to an integer overflow in the PyString_DecodeEscape function in stringobject.c, resulting in heap-based buffer overflow (and possible arbitrary code exe"}