{"action":"Upgrade glibc to 2.6-2 or later.","affected":[{"fixed":"2.6-2","introduced":"0"}],"component":"glibc","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2.6-2"],"id":"tcs_01M5N8TVF6YCWTK46ENDZA3MBM","modified_at":"2026-10-21T17:47:44.521362930Z","published_at":"2007-07-03T21:30:00Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2007-3508","https://security-tracker.debian.org/tracker/CVE-2007-3508"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2007-3508#Debian:13/glibc","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2007-3508"}],"summary":"Integer overflow in the process_envvars function in elf/rtld.c in glibc before 2.5-rc4 might allow local users to execute arbitrary code via a large LD_HWCAP_MASK environment variable value. NOTE: the"}