{"action":"Upgrade org.apache.hop:hop to 2.8.0 or later.","affected":[{"fixed":"2.8.0","introduced":"0"}],"component":"org.apache.hop:hop","cve_ids":["CVE-2024-24683"],"ecosystem":"Maven","epss":0.01239,"exploited":false,"fixed_versions":["2.8.0"],"ghsa_id":"GHSA-f6g6-pjgc-5cj5","id":"tcs_01M5N8V6X6NRFM868AXWJKHC4A","modified_at":"2024-11-22T21:07:41.819102Z","published_at":"2024-03-19T09:30:33Z","references":["https://osv.dev/vulnerability/GHSA-f6g6-pjgc-5cj5","https://nvd.nist.gov/vuln/detail/CVE-2024-24683","https://github.com/apache/hop","https://lists.apache.org/thread/ts203zssv1n9qth1wdlhk2bhos3vcq6t","http://www.openwall.com/lists/oss-security/2024/03/18/1"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"GHSA-f6g6-pjgc-5cj5","url":"https://osv.dev/vulnerability/GHSA-f6g6-pjgc-5cj5"}],"summary":"Improper Input Validation vulnerability in Apache Hop Engine"}