{"action":"Upgrade org.jboss.hal:hal-console to 3.7.11.Final or later.","affected":[{"fixed":"3.7.11.Final","introduced":"0"}],"component":"org.jboss.hal:hal-console","cve_ids":["CVE-2025-2901"],"ecosystem":"Maven","exploited":false,"fixed_versions":["3.7.11.Final"],"ghsa_id":"GHSA-f7jh-m6wp-jm7f","id":"tcs_01M5N8VDX3F2GRTB4TXXZBSAPA","modified_at":"2026-09-10T03:50:24.522690568Z","published_at":"2025-05-06T18:51:27Z","references":["https://osv.dev/vulnerability/GHSA-f7jh-m6wp-jm7f","https://github.com/hal/console/security/advisories/GHSA-f7jh-m6wp-jm7f","https://nvd.nist.gov/vuln/detail/CVE-2025-2901","https://github.com/hal/console/commit/216de3b8aa82ea92df10cc296d88c68467cf2c52","https://access.redhat.com/security/cve/CVE-2025-2901","https://bugzilla.redhat.com/show_bug.cgi?id=2355685","https://github.com/hal/console","https://github.com/hal/console/releases/tag/v3.7.11"],"severity":{"label":"medium","score":4.6},"sources":[{"source":"osv","source_id":"GHSA-f7jh-m6wp-jm7f","url":"https://osv.dev/vulnerability/GHSA-f7jh-m6wp-jm7f"}],"summary":"HAL Cross Site Scripting (XSS) vulnerability of user input when storing it in a data store"}