{"action":"Upgrade com.thoughtworks.xstream:xstream to 1.4.20 or later.","affected":[{"fixed":"1.4.20","introduced":"0"}],"component":"com.thoughtworks.xstream:xstream","cve_ids":["CVE-2022-40151"],"ecosystem":"Maven","epss":0.02222,"exploited":false,"fixed_versions":["1.4.20"],"ghsa_id":"GHSA-f8cc-g7j8-xxpm","id":"tcs_01M5N8VFGGECSKD7MT31WYZJZR","modified_at":"2023-11-08T04:10:22.920578Z","published_at":"2022-12-30T16:58:39Z","references":["https://osv.dev/vulnerability/GHSA-f8cc-g7j8-xxpm","https://github.com/x-stream/xstream/security/advisories/GHSA-f8cc-g7j8-xxpm","https://nvd.nist.gov/vuln/detail/CVE-2022-40151","https://github.com/x-stream/xstream/issues/304","https://github.com/x-stream/xstream/issues/314","https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=47367","https://github.com/x-stream/xstream","https://x-stream.github.io/CVE-2022-40151.html"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-f8cc-g7j8-xxpm","url":"https://osv.dev/vulnerability/GHSA-f8cc-g7j8-xxpm"}],"summary":"XStream can cause a Denial of Service by injecting deeply nested objects raising a stack overflow"}