{"action":"Upgrade org.jenkins-ci.plugins:htmlpublisher to 427.1 or later.","affected":[{"fixed":"427.1","introduced":"0"}],"component":"org.jenkins-ci.plugins:htmlpublisher","cve_ids":["CVE-2026-42524"],"ecosystem":"Maven","epss":0.00281,"exploited":false,"fixed_versions":["427.1"],"ghsa_id":"GHSA-f8h4-46xv-h7jj","id":"tcs_01M5N8VFP2ES1F1W9D23HNTD7H","modified_at":"2026-05-06T23:11:23.875235Z","published_at":"2026-04-29T15:30:39Z","references":["https://osv.dev/vulnerability/GHSA-f8h4-46xv-h7jj","https://nvd.nist.gov/vuln/detail/CVE-2026-42524","https://github.com/jenkinsci/htmlpublisher-plugin","https://www.jenkins.io/security/advisory/2026-04-29/#SECURITY-3706"],"severity":{"label":"high","score":8},"sources":[{"source":"osv","source_id":"GHSA-f8h4-46xv-h7jj","url":"https://osv.dev/vulnerability/GHSA-f8h4-46xv-h7jj"}],"summary":"Jenkins HTML Publisher Plugin has a XSS vulnerability in the legacy wrapper file"}