{"action":"Upgrade org.apache.tomee:tomee-webapp to 7.0.5 or later.","affected":[{"fixed":"7.0.5","introduced":"0"}],"component":"org.apache.tomee:tomee-webapp","cve_ids":["CVE-2018-8031"],"ecosystem":"Maven","epss":0.02003,"exploited":false,"fixed_versions":["7.0.5"],"ghsa_id":"GHSA-fg44-w3fr-hgxv","id":"tcs_01M5N8VYR1CN005K02R7BHJC5G","modified_at":"2023-11-08T04:00:24.855354Z","published_at":"2022-05-14T01:30:10Z","references":["https://osv.dev/vulnerability/GHSA-fg44-w3fr-hgxv","https://nvd.nist.gov/vuln/detail/CVE-2018-8031","https://github.com/apache/tomee/commit/b8bbf50c23ce97dd64f3a5d77f78f84e47579863","https://github.com/apache/tomee","https://lists.apache.org/thread.html/c4b0d83a534d6cdf2de54dbbd00e3538072ac2e360781b784608ed0d@%3Cdev.tomee.apache.org%3E"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"GHSA-fg44-w3fr-hgxv","url":"https://osv.dev/vulnerability/GHSA-fg44-w3fr-hgxv"}],"summary":"Apache TomEE console vulnerable to Cross-site Scripting"}