{"action":"Upgrade org.geoserver:gs-restconfig to 2.23.3 or later.","affected":[{"fixed":"2.23.3","introduced":"0"}],"component":"org.geoserver:gs-restconfig","cve_ids":["CVE-2023-51445"],"ecosystem":"Maven","epss":0.00487,"exploited":false,"fixed_versions":["2.23.3"],"ghsa_id":"GHSA-fh7p-5f6g-vj2w","id":"tcs_01M5N8W1RQJWM3GN4TQW2F3ZEE","modified_at":"2024-03-20T21:04:09Z","published_at":"2024-03-20T14:58:17Z","references":["https://osv.dev/vulnerability/GHSA-fh7p-5f6g-vj2w","https://github.com/geoserver/geoserver/security/advisories/GHSA-fh7p-5f6g-vj2w","https://nvd.nist.gov/vuln/detail/CVE-2023-51445","https://github.com/geoserver/geoserver/pull/7161","https://github.com/geoserver/geoserver/commit/7db985738ff2422019ccac974cf547bae5770cad","https://github.com/geoserver/geoserver","https://osgeo-org.atlassian.net/browse/GEOS-11148"],"severity":{"label":"medium","score":4.8},"sources":[{"source":"osv","source_id":"GHSA-fh7p-5f6g-vj2w","url":"https://osv.dev/vulnerability/GHSA-fh7p-5f6g-vj2w"}],"summary":"Stored Cross-Site Scripting (XSS) vulnerability in GeoServer's REST Resources API"}