{"action":"Upgrade glibc to 2.7-1 or later.","affected":[{"fixed":"2.7-1","introduced":"0"}],"component":"glibc","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.7-1"],"id":"tcs_01M5N8W80F0Z4057MNSR87VDAQ","modified_at":"2026-10-21T17:47:45.260497734Z","published_at":"2007-09-12T20:17:00Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2007-4840","https://security-tracker.debian.org/tracker/CVE-2007-4840"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2007-4840#Debian:14/glibc","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2007-4840"}],"summary":"PHP 5.2.4 and earlier allows context-dependent attackers to cause a denial of service (application crash) via (1) a long string in the out_charset parameter to the iconv function; or a long string in"}