{"action":"Upgrade xen to 4.9.0-r0 or later.","affected":[{"fixed":"4.9.0-r0","introduced":"0"}],"component":"xen","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.22","exploited":false,"fixed_versions":["4.9.0-r0"],"id":"tcs_01M5N8W90F8SPP7FNHWVSF47N3","modified_at":"2026-06-15T18:18:06.726077160Z","published_at":"2017-07-05T01:29:00.673Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2017-10915","https://security.alpinelinux.org/vuln/CVE-2017-10915"],"severity":{"label":"critical","score":9},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2017-10915#Alpine:v3.22/xen","url":"https://osv.dev/vulnerability/ALPINE-CVE-2017-10915"}],"summary":"The shadow-paging feature in Xen through 4.8.x mismanages page references and consequently introduces a race condition, which allows guest OS users to obtain Xen privileges, aka XSA-219."}