{"action":"Upgrade xen to 4.9.0-r0 or later.","affected":[{"fixed":"4.9.0-r0","introduced":"0"}],"component":"xen","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.7","exploited":false,"fixed_versions":["4.9.0-r0"],"id":"tcs_01M5N8WHR4E8TJYY7SATT029SD","modified_at":"2026-06-15T18:18:06.726690776Z","published_at":"2017-07-05T01:29:00.737Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2017-10917","https://security.alpinelinux.org/vuln/CVE-2017-10917"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2017-10917#Alpine:v3.7/xen","url":"https://osv.dev/vulnerability/ALPINE-CVE-2017-10917"}],"summary":"Xen through 4.8.x does not validate the port numbers of polled event channel ports, which allows guest OS users to cause a denial of service (NULL pointer dereference and host OS crash) or possibly ob"}