{"action":"Upgrade rails to 1.2.5-1 or later.","affected":[{"fixed":"1.2.5-1","introduced":"0"}],"component":"rails","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.2.5-1"],"id":"tcs_01M5N8WV3TZGY5P4G8253WSD3R","modified_at":"2026-10-21T17:47:34.423037027Z","published_at":"2007-10-19T23:17:00Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2007-5379","https://security-tracker.debian.org/tracker/CVE-2007-5379"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2007-5379","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2007-5379"}],"summary":"Rails before 1.2.4, as used for Ruby on Rails, allows remote attackers and ActiveResource servers to determine the existence of arbitrary files and read arbitrary XML files via the Hash.from_xml (Hash"}