{"action":"Upgrade org.apache.neethi:neethi to 3.2.2 or later.","affected":[{"fixed":"3.2.2","introduced":"0"}],"component":"org.apache.neethi:neethi","cve_ids":["CVE-2026-42402"],"ecosystem":"Maven","epss":0.00711,"exploited":false,"fixed_versions":["3.2.2"],"ghsa_id":"GHSA-g36m-9g3m-2vmp","id":"tcs_01M5N8X4PA5VRXPXJBJ4AQ7Y4R","modified_at":"2026-09-10T03:51:05.517258827Z","published_at":"2026-05-01T09:30:25Z","references":["https://osv.dev/vulnerability/GHSA-g36m-9g3m-2vmp","https://nvd.nist.gov/vuln/detail/CVE-2026-42402","https://github.com/apache/ws-neethi","https://lists.apache.org/thread/p826j0phhmr9f83wzpmys1y0bdfrr2q4","http://www.openwall.com/lists/oss-security/2026/05/01/6"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-g36m-9g3m-2vmp","url":"https://osv.dev/vulnerability/GHSA-g36m-9g3m-2vmp"}],"summary":"Apache Neethi is vulnerable to a Denial of Service attack through algorithmic complexity in policy normalization"}