{"action":"Upgrade org.geoserver.extension:gs-db2 to 2.27.0 or later.","affected":[{"fixed":"2.27.0","introduced":"0"}],"component":"org.geoserver.extension:gs-db2","cve_ids":["CVE-2025-27511"],"ecosystem":"Maven","epss":0.01074,"exploited":false,"fixed_versions":["2.27.0"],"ghsa_id":"GHSA-g628-r368-6vh7","id":"tcs_01M5N8XGJYY9RQST9FJCH894EE","modified_at":"2026-07-15T22:00:51.215924098Z","published_at":"2026-06-11T20:34:00Z","references":["https://osv.dev/vulnerability/GHSA-g628-r368-6vh7","https://github.com/geoserver/geoserver/security/advisories/GHSA-g628-r368-6vh7","https://nvd.nist.gov/vuln/detail/CVE-2025-27511","https://github.com/geoserver/geoserver","https://github.com/geoserver/geoserver/releases/tag/2.27.0","https://nvd.nist.gov/vuln/detail/cve-2023-27867","https://osgeo-org.atlassian.net/browse/GEOT-7725"],"severity":{"label":"high","score":7.2},"sources":[{"source":"osv","source_id":"GHSA-g628-r368-6vh7","url":"https://osv.dev/vulnerability/GHSA-g628-r368-6vh7"}],"summary":"GeoServer DB2 DataStore Extension has a JNDI Vulnerability via Store Connection"}