{"action":"Upgrade io.jenkins.blueocean:blueocean-pipeline-scm-api to 1.25.4 or later.","affected":[{"fixed":"1.25.4","introduced":"0"}],"component":"io.jenkins.blueocean:blueocean-pipeline-scm-api","cve_ids":["CVE-2022-30952"],"ecosystem":"Maven","epss":0.01024,"exploited":false,"fixed_versions":["1.25.4"],"ghsa_id":"GHSA-g74w-93cp-5p3p","id":"tcs_01M5N8XM9DNEZMZ88G1V90KFGS","modified_at":"2024-02-16T08:16:20.668202Z","published_at":"2022-05-18T00:00:40Z","references":["https://osv.dev/vulnerability/GHSA-g74w-93cp-5p3p","https://nvd.nist.gov/vuln/detail/CVE-2022-30952","https://github.com/jenkinsci/blueocean-plugin/commit/c4beeda0b574c297ac664511029feed0a15abaf1","https://github.com/jenkinsci/blueocean-plugin/tree/master/blueocean-pipeline-scm-api","https://www.jenkins.io/security/advisory/2022-05-17/#SECURITY-714","http://www.openwall.com/lists/oss-security/2022/05/17/8"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"GHSA-g74w-93cp-5p3p","url":"https://osv.dev/vulnerability/GHSA-g74w-93cp-5p3p"}],"summary":"Insufficiently Protected Credentials in Jenkins Pipeline SCM API for Blue Ocean Plugin"}