{"action":"Upgrade org.jenkins-ci.plugins:codedx to 4.0.0 or later.","affected":[{"fixed":"4.0.0","introduced":"0"}],"component":"org.jenkins-ci.plugins:codedx","cve_ids":["CVE-2023-2195"],"ecosystem":"Maven","epss":0.00411,"exploited":false,"fixed_versions":["4.0.0"],"ghsa_id":"GHSA-gx2j-5vc3-3794","id":"tcs_01M5N8Z6PYS1M1P57595WEJWZ6","modified_at":"2024-02-16T08:05:21.981212Z","published_at":"2023-05-16T21:30:22Z","references":["https://osv.dev/vulnerability/GHSA-gx2j-5vc3-3794","https://nvd.nist.gov/vuln/detail/CVE-2023-2195","https://github.com/jenkinsci/codedx-plugin/commit/0214f30488ea8481f01e4b14a861e13d75bebb8b","https://www.jenkins.io/security/advisory/2023-05-16/#SECURITY-3118"],"severity":{"label":"medium","score":4.3},"sources":[{"source":"osv","source_id":"GHSA-gx2j-5vc3-3794","url":"https://osv.dev/vulnerability/GHSA-gx2j-5vc3-3794"}],"summary":"Jenkins Code Dx Plugin cross-site request forgery vulnerability"}