{"action":"Upgrade org.apache.opennlp:opennlp-tools to 1.8.2 or later.","affected":[{"fixed":"1.8.2","introduced":"1.5.0"}],"component":"org.apache.opennlp:opennlp-tools","cve_ids":["CVE-2017-12620"],"ecosystem":"Maven","epss":0.03041,"exploited":false,"fixed_versions":["1.8.2"],"ghsa_id":"GHSA-h22x-hm8g-rxpg","id":"tcs_01M5N8ZB0BAS6E5GTJW5JBPFHF","modified_at":"2023-11-08T03:58:53.308326Z","published_at":"2022-05-17T00:29:00Z","references":["https://osv.dev/vulnerability/GHSA-h22x-hm8g-rxpg","https://nvd.nist.gov/vuln/detail/CVE-2017-12620","http://opennlp.apache.org/news/cve-2017-12620.html"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-h22x-hm8g-rxpg","url":"https://osv.dev/vulnerability/GHSA-h22x-hm8g-rxpg"}],"summary":"Improper Restriction of XML External Entity Reference in Apache OpenNLP"}