{"action":"Upgrade xorg-server to 1.19.5-r0 or later.","affected":[{"fixed":"1.19.5-r0","introduced":"0"}],"component":"xorg-server","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.11","exploited":false,"fixed_versions":["1.19.5-r0"],"id":"tcs_01M5N8ZC5268TZBRYD2WDV8J2R","modified_at":"2026-11-03T06:30:26.604373698Z","published_at":"2018-01-24T15:29:00.247Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2017-12176","https://security.alpinelinux.org/vuln/CVE-2017-12176"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2017-12176#Alpine:v3.11/xorg-server","url":"https://osv.dev/vulnerability/ALPINE-CVE-2017-12176"}],"summary":"xorg-x11-server before 1.19.5 was missing extra length validation in ProcEstablishConnection function allowing malicious X client to cause X server to crash or possibly execute arbitrary code."}