{"action":"Upgrade xorg-server to 1.19.5-r0 or later.","affected":[{"fixed":"1.19.5-r0","introduced":"0"}],"component":"xorg-server","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.6","exploited":false,"fixed_versions":["1.19.5-r0"],"id":"tcs_01M5N8ZEV2KYAFRKH91B72D553","modified_at":"2026-06-15T18:24:34.705577257Z","published_at":"2018-01-24T15:29:00.370Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2017-12178","https://security.alpinelinux.org/vuln/CVE-2017-12178"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2017-12178#Alpine:v3.6/xorg-server","url":"https://osv.dev/vulnerability/ALPINE-CVE-2017-12178"}],"summary":"xorg-x11-server before 1.19.5 had wrong extra length check in ProcXIChangeHierarchy function allowing malicious X client to cause X server to crash or possibly execute arbitrary code."}