{"action":"Upgrade xorg-server to 1.19.5-r0 or later.","affected":[{"fixed":"1.19.5-r0","introduced":"0"}],"component":"xorg-server","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.8","exploited":false,"fixed_versions":["1.19.5-r0"],"id":"tcs_01M5N8ZGVMJYD136T3SMAZP1J9","modified_at":"2026-06-15T18:24:35.575878672Z","published_at":"2018-01-24T15:29:00.433Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2017-12179","https://security.alpinelinux.org/vuln/CVE-2017-12179"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2017-12179#Alpine:v3.8/xorg-server","url":"https://osv.dev/vulnerability/ALPINE-CVE-2017-12179"}],"summary":"xorg-x11-server before 1.19.5 was vulnerable to integer overflow in (S)ProcXIBarrierReleasePointer functions allowing malicious X client to cause X server to crash or possibly execute arbitrary code."}