{"action":"Upgrade xorg-server to 1.19.5-r0 or later.","affected":[{"fixed":"1.19.5-r0","introduced":"0"}],"component":"xorg-server","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.10","exploited":false,"fixed_versions":["1.19.5-r0"],"id":"tcs_01M5N8ZMMRG97RA29S2H8WPVPT","modified_at":"2026-06-15T18:24:11.954286662Z","published_at":"2018-01-24T15:29:00.700Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2017-12183","https://security.alpinelinux.org/vuln/CVE-2017-12183"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2017-12183","url":"https://osv.dev/vulnerability/ALPINE-CVE-2017-12183"}],"summary":"xorg-x11-server before 1.19.5 was missing length validation in XFIXES extension allowing malicious X client to cause X server to crash or possibly execute arbitrary code."}