{"action":"Upgrade org.apache.xmlgraphics:batik to 1.15 or later.","affected":[{"fixed":"1.15","introduced":"1.0"}],"component":"org.apache.xmlgraphics:batik","cve_ids":["CVE-2022-40146"],"ecosystem":"Maven","epss":0.07431,"exploited":false,"fixed_versions":["1.15"],"ghsa_id":"GHSA-h4qg-p7r2-cpg3","id":"tcs_01M5N8ZNFJ6QB6FH79C20D7YYF","modified_at":"2025-11-03T23:01:26.554368Z","published_at":"2022-09-23T00:00:40Z","references":["https://osv.dev/vulnerability/GHSA-h4qg-p7r2-cpg3","https://nvd.nist.gov/vuln/detail/CVE-2022-40146","https://github.com/apache/xmlgraphics-batik","https://issues.apache.org/jira/browse/BATIK-1335","https://lists.apache.org/thread/hxtddqjty2sbs12y97c8g7xfh17jzxsx","https://lists.debian.org/debian-lts-announce/2023/10/msg00021.html","https://lists.debian.org/debian-lts-announce/2025/07/msg00006.html","https://security.gentoo.org/glsa/202401-11"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-h4qg-p7r2-cpg3","url":"https://osv.dev/vulnerability/GHSA-h4qg-p7r2-cpg3"}],"summary":"Apache Batik vulnerable to Server-Side Request Forgery"}