{"action":"Upgrade io.ktor:ktor to 2.1.0 or later.","affected":[{"fixed":"2.1.0","introduced":"0"}],"component":"io.ktor:ktor","cve_ids":["CVE-2022-38180"],"ecosystem":"Maven","epss":0.00733,"exploited":false,"fixed_versions":["2.1.0"],"ghsa_id":"GHSA-hccx-cg4v-hrjx","id":"tcs_01M5N90A3Z4PTH4XWBACCBF1W5","modified_at":"2024-02-22T05:34:42.816726Z","published_at":"2022-08-13T00:00:43Z","references":["https://osv.dev/vulnerability/GHSA-hccx-cg4v-hrjx","https://nvd.nist.gov/vuln/detail/CVE-2022-38180","https://github.com/ktorio/ktor/pull/3092","https://github.com/ktorio/ktor","https://www.jetbrains.com/privacy-security/issues-fixed"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"GHSA-hccx-cg4v-hrjx","url":"https://osv.dev/vulnerability/GHSA-hccx-cg4v-hrjx"}],"summary":"JetBrain Ktor before 2.1.0 vulnerable to selection of wrong authentication provider"}