{"action":"Upgrade org.apache.commons:commons-lang3 to 3.18.0 or later.","affected":[{"fixed":"3.18.0","introduced":"3.0"}],"component":"org.apache.commons:commons-lang3","cve_ids":["CVE-2025-48924"],"ecosystem":"Maven","epss":0.02632,"exploited":false,"fixed_versions":["3.18.0"],"ghsa_id":"GHSA-j288-q9x7-2f5v","id":"tcs_01M5N91S6XWBNXAD79D6YKG44J","modified_at":"2026-09-10T03:50:26.176912270Z","published_at":"2025-07-11T15:31:37Z","references":["https://osv.dev/vulnerability/GHSA-j288-q9x7-2f5v","https://nvd.nist.gov/vuln/detail/CVE-2025-48924","https://github.com/apache/commons-lang/commit/b424803abdb2bec818e4fbcb251ce031c22aca53","https://github.com/apache/commons-lang","https://lists.apache.org/thread/bgv0lpswokgol11tloxnjfzdl7yrc1g1","https://lists.debian.org/debian-lts-announce/2025/08/msg00000.html","https://lists.debian.org/debian-lts-announce/2025/08/msg00026.html","https://lists.debian.org/debian-lts-announce/2025/09/msg00032.html","https://lists.debian.org/debian-lts-announce/2025/09/msg00036.html","http://www.openwall.com/lists/oss-security/2025/07/11/1"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"GHSA-j288-q9x7-2f5v","url":"https://osv.dev/vulnerability/GHSA-j288-q9x7-2f5v"}],"summary":"Apache Commons Lang is vulnerable to Uncontrolled Recursion when processing long inputs"}