{"action":"Upgrade org.jvnet.hudson.main:hudson-core to 3.3.2 or later.","affected":[{"fixed":"3.3.2","introduced":"0"}],"component":"org.jvnet.hudson.main:hudson-core","cve_ids":["CVE-2015-8031"],"ecosystem":"Maven","epss":0.01667,"exploited":false,"fixed_versions":["3.3.2"],"ghsa_id":"GHSA-j3h2-8mf8-j5r2","id":"tcs_01M5N91X4JVAJPS0M27MG2CZHN","modified_at":"2023-11-08T03:58:01.652697Z","published_at":"2022-07-15T18:12:47Z","references":["https://osv.dev/vulnerability/GHSA-j3h2-8mf8-j5r2","https://nvd.nist.gov/vuln/detail/CVE-2015-8031","https://github.com/advisories/GHSA-j3h2-8mf8-j5r2","https://github.com/hudson/hudson-2.x","https://security.snyk.io/vuln/SNYK-JAVA-ORGJVNETHUDSONMAIN-31221","https://wiki.eclipse.org/Hudson-ci/alerts/CVE-2015-8031"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-j3h2-8mf8-j5r2","url":"https://osv.dev/vulnerability/GHSA-j3h2-8mf8-j5r2"}],"summary":"Hudson XML API susceptible to External Entity Injection Vunerability prior to v3.3.2"}