{"action":"Upgrade vim to 2:7.2.010-1 or later.","affected":[{"fixed":"2:7.2.010-1","introduced":"0"}],"component":"vim","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2:7.2.010-1"],"id":"tcs_01M5N928A1QBZKDMYDMSX3N03P","modified_at":"2026-10-23T17:47:33.318236955Z","published_at":"2009-02-21T22:30:00.217Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2008-3074","https://security-tracker.debian.org/tracker/CVE-2008-3074"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2008-3074","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2008-3074"}],"summary":"The shellescape function in Vim 7.0 through 7.2, including 7.2a.10, allows user-assisted attackers to execute arbitrary code via the \"!\" (exclamation point) shell metacharacter in (1) the filename of"}