{"action":"Upgrade cups to 1.3.8-1lenny2 or later.","affected":[{"fixed":"1.3.8-1lenny2","introduced":"0"}],"component":"cups","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["1.3.8-1lenny2"],"id":"tcs_01M5N92WWE315ERDQQ8TBD2B5M","modified_at":"2026-10-23T17:47:41.508479723Z","published_at":"2008-10-14T21:10:35.627Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2008-3640","https://security-tracker.debian.org/tracker/CVE-2008-3640"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2008-3640#Debian:13/cups","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2008-3640"}],"summary":"Integer overflow in the WriteProlog function in texttops in CUPS before 1.3.9 allows remote attackers to execute arbitrary code via a crafted PostScript file that triggers a heap-based buffer overflow"}