{"action":"Upgrade cups to 1.3.8-1lenny2 or later.","affected":[{"fixed":"1.3.8-1lenny2","introduced":"0"}],"component":"cups","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["1.3.8-1lenny2"],"id":"tcs_01M5N92XFC9G52GKPX0DY54SGS","modified_at":"2026-10-23T17:47:46.870476295Z","published_at":"2008-10-10T10:30:03.077Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2008-3641","https://security-tracker.debian.org/tracker/CVE-2008-3641"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2008-3641#Debian:14/cups","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2008-3641"}],"summary":"The Hewlett-Packard Graphics Language (HPGL) filter in CUPS before 1.3.9 allows remote attackers to execute arbitrary code via crafted pen width and pen color opcodes that overwrite arbitrary memory."}