{"action":"Upgrade org.jboss.hal:hal-console to 3.7.7.Final or later.","affected":[{"fixed":"3.7.7.Final","introduced":"0"}],"component":"org.jboss.hal:hal-console","cve_ids":["CVE-2025-23366"],"ecosystem":"Maven","epss":0.00461,"exploited":false,"fixed_versions":["3.7.7.Final"],"ghsa_id":"GHSA-jhvj-f397-8w6q","id":"tcs_01M5N931HM18R1P8R4KW58NX7E","modified_at":"2026-09-10T03:50:22.002017317Z","published_at":"2025-01-16T19:05:39Z","references":["https://osv.dev/vulnerability/GHSA-jhvj-f397-8w6q","https://github.com/hal/console/security/advisories/GHSA-jhvj-f397-8w6q","https://access.redhat.com/security/cve/CVE-2025-23366","https://bugzilla.redhat.com/show_bug.cgi?id=2337619","https://github.com/hal/console","https://github.com/hal/console/releases/tag/v3.7.7"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"GHSA-jhvj-f397-8w6q","url":"https://osv.dev/vulnerability/GHSA-jhvj-f397-8w6q"}],"summary":"HAL Console has a Cross Site Scripting (XSS) vulnerability of user input"}