{"action":"Upgrade org.apache.geode:geode-core to 1.5.0 or later.","affected":[{"fixed":"1.5.0","introduced":"1.0.0"}],"component":"org.apache.geode:geode-core","cve_ids":["CVE-2017-15695"],"ecosystem":"Maven","epss":0.02513,"exploited":false,"fixed_versions":["1.5.0"],"ghsa_id":"GHSA-jmg4-x4vp-6c6x","id":"tcs_01M5N937KF75P6AZMRYMWTK6T4","modified_at":"2024-04-12T21:16:36.327818Z","published_at":"2022-05-13T01:18:20Z","references":["https://osv.dev/vulnerability/GHSA-jmg4-x4vp-6c6x","https://nvd.nist.gov/vuln/detail/CVE-2017-15695","https://github.com/apache/geode/pull/1258","https://github.com/apache/geode/commit/00be4f9774e1adf8e7ccc2664da8005fc30bb11d","https://github.com/apache/geode/commit/49d28f93fd2ef069693ce15d124ef3a29f22fb7d","https://github.com/apache/geode/commit/6df14c8b1e3c644f9f810149e80bba0c2f073dab","https://github.com/apache/geode/commit/740289c61d60256c6270756bc84b9e24b76e4913","https://github.com/apache/geode/commit/90f8f6242927c5e16da64f38bba9abf3d450a305","https://github.com/apache/geode/commit/954ccb545d24a9c9a35cbd84023a4d7e07032de0","https://github.com/apache/geode/commit/aa469239860778eb46e09dd7b390aee08f152480","https://cwiki.apache.org/confluence/display/GEODE/Release+Notes#ReleaseNotes-SecurityVulnerabilities","https://github.com/apache/geode","https://issues.apache.org/jira/browse/GEODE-3974","https://lists.apache.org/thread.html/dc8875c0b924885a884eba6d5bd7dc3f123411b2d33cffd00e351c99@%3Cuser.geode.apache.org%3E"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"GHSA-jmg4-x4vp-6c6x","url":"https://osv.dev/vulnerability/GHSA-jmg4-x4vp-6c6x"}],"summary":"Apache Geode vulnerable to Incorrect Authorization"}