{"action":"Upgrade org.opennms:opennms to 27.1.1 or later.","affected":[{"fixed":"27.1.1","introduced":"1.0.0"}],"component":"org.opennms:opennms","cve_ids":["CVE-2021-25929"],"ecosystem":"Maven","epss":0.0102,"exploited":false,"fixed_versions":["27.1.1"],"ghsa_id":"GHSA-jmv4-73v2-pvgc","id":"tcs_01M5N938VWFQT4MXTNXNQKGF4Q","modified_at":"2025-05-01T00:21:33Z","published_at":"2021-05-25T18:46:58Z","references":["https://osv.dev/vulnerability/GHSA-jmv4-73v2-pvgc","https://nvd.nist.gov/vuln/detail/CVE-2021-25929","https://github.com/OpenNMS/opennms/commit/66c1f626bf38a7d1a9530b4d68598269ee5245a2","https://github.com/OpenNMS/opennms/commit/eb08b5ed4c5548f3e941a1f0d0363ae4439fa98c","https://github.com/OpenNMS/opennms","https://www.whitesourcesoftware.com/vulnerability-database/CVE-2021-25929"],"severity":{"label":"medium","score":4.8},"sources":[{"source":"osv","source_id":"GHSA-jmv4-73v2-pvgc","url":"https://osv.dev/vulnerability/GHSA-jmv4-73v2-pvgc"}],"summary":"Cross-site Scripting in OpenNMS Horizon"}