{"action":"Upgrade ed to 0.7-2 or later.","affected":[{"fixed":"0.7-2","introduced":"0"}],"component":"ed","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.7-2"],"id":"tcs_01M5N93A1FP7X48C5RMCPY2FD1","modified_at":"2026-10-23T17:47:44.029902691Z","published_at":"2008-09-04T18:41:00Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2008-3916","https://security-tracker.debian.org/tracker/CVE-2008-3916"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2008-3916#Debian:14/ed","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2008-3916"}],"summary":"Heap-based buffer overflow in the strip_escapes function in signal.c in GNU ed before 1.0 allows context-dependent or user-assisted attackers to execute arbitrary code via a long filename. NOTE: since"}