{"action":"Upgrade rails to 2.1.0-1 or later.","affected":[{"fixed":"2.1.0-1","introduced":"0"}],"component":"rails","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.1.0-1"],"id":"tcs_01M5N93GJZTYY8C3TVYS3E2CGS","modified_at":"2026-10-23T17:47:21.517764026Z","published_at":"2008-09-30T17:22:09.147Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2008-4094","https://security-tracker.debian.org/tracker/CVE-2008-4094"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2008-4094#Debian:14/rails","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2008-4094"}],"summary":"Multiple SQL injection vulnerabilities in Ruby on Rails before 2.1.1 allow remote attackers to execute arbitrary SQL commands via the (1) :limit and (2) :offset parameters, related to ActiveRecord, Ac"}