{"action":"Upgrade mercurial to 1.0.1-5.1 or later.","affected":[{"fixed":"1.0.1-5.1","introduced":"0"}],"component":"mercurial","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["1.0.1-5.1"],"id":"tcs_01M5N93PRF7E9DQC537D8F24FZ","modified_at":"2026-10-23T17:47:25.548837729Z","published_at":"2008-09-27T10:30:03.647Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2008-4297","https://security-tracker.debian.org/tracker/CVE-2008-4297"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2008-4297#Debian:13/mercurial","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2008-4297"}],"summary":"Mercurial before 1.0.2 does not enforce the allowpull permission setting for a pull operation from hgweb, which allows remote attackers to read arbitrary files from a repository via an \"hg pull\" reque"}